Logic Glitch - System over load

andrew

open your mind
Hi all -

I wonder if any of you are quite happy on Logic 5.5.1 on a PC like me? (No it's not the crack, I've been updating since V4)

My DAW is a P4 3.01 Ghz with 1gb of ram, using a Creamware Scope soundcard.

I have one small problem. When i move Windows around or change parameters on say the soundcard mixer, while Logic is playing, Logic will quite regularly (and i mean at least once a minute) give me it's

"ASIO : System Overload. The audio engine was not able to process all the required data in time" message and stop playing.

This is quite annoying as say I want to operate controls on a plugin running on my soundcard (ie a different windows app) the sound will suddenly glitch and stop. Obviously i want to be able to hear what I'm doing over time without having to keep hitting 'play' in logic.

Anyone got any ideas?

Thanks

Andrew
 

KungFuHamster

Fabmeister
iI had this problem with my Marian Marc 4 MIDI card on my old Athlon 1800XP+ box - and I eventually solved it, however it was about a year ago and I can't remember with 100% certainty that what I'm about to say is spot on!

I *believe*, however, that the default Logic 5.51 song has audio routing for a great many channels - 64 I think. I reduced this count to just the 4 actual physical outputs, and bingo, problem gone. My old 1800XP+ box was always a tad marginal for serious plugin use before this fix, but was reasonably useful afterwards. Glad I updated to a 64/3000+ though. I'm at work right now and can't remember the exact menu option to pull up the routing window, but I think it's "Options" -> "Audio Configuration" , or possibly "audio routing" or the like.

Still like using Logic 5.51 though :Smile3: I've resisted the Dark Temptation :unsure: of Cubase up until now... will I be able to hold out until I can buy an Intel based Apple? :confused:
 

andrew

open your mind
thanks everyone for responding :Smile3:

yes have tweeked xp for audio -

adjused for best performance not appearance & bckgrnd processes, programs get better performance than system cache, 1.5mb virtual memory, msconfigged it down to minimum processes, turned off system restore, erm.. anything i've missed you can think of ?

I'm running 32 stereo outputs from logic into the virtual inputs of the creamware mixer - ie each track in logic be it audio or an instrument goes to a different logic output pair, which is then mixed in my soundcard as this is the recommended way to use the scope software - as opposed to mixing in logic and outputting everything out into creamware thru one pair of outputs. As you say, logic has 64 outputs, but i need them all on to mix in this way. I've had a hunt for the setting to reduce this number anyway, not in audio preferences or the audio hardware and drivers page. I'm not sure I've ever seen this.

hmmmm... i can kinda get round the situation by operating the mixer in logic with each track routed to a separate output from logic and into a track on scope, with each scope channe set to 0db - then am still taking advantage of 'mixing' in scope, or perhaps even running my scope card in 'xtc' mode, which means the plugins run in logic, but this way not all the creamware synths actually work (not implemented properly in this mode) - would be great not to have to do that tho
 

dogcow

SMOKER
http://www.musicxp.net

i find that the most important factor for logic performance are good soundcard drivers. i used to have an m-audio 2496 and had all sorts of hickups with both logic and sounddiver. since i got an RME card all of the problems magically dissapeared.
 

andrew

open your mind
Colin OOOD said:
What video card are you running? Is the video card sharing an IRQ with the Scope card? Try moving the Scope to a different PCI slot. When did you last update your video drivers?

the scope card is on irq 5 with a few other bits and bobs like the network card etc

the graffix card is on irq 10. I have my machine in non acpi mode btw.

Just updated to the newest version of my video card's drivers from their website..

No noticable change in behavior. When moving large windows from screen to screen i get the glitch, but am able to edit parameters in the creamware plugin I've been using today with no glitching, so it aint all bad...

Thanks
 

Triskele

Korma-kaze
Colin here Rob Triskele's computer... Try lowering the Video Hardware Acceleration slider - it's in the Troubleshooting page of the Advanced section of the Graphics Properties window (right-click on desktop, select Properties, select Settings, click Advanced, select Troubleshooting).
 

nomis

bumbalumba cruiser
andrew said:
the scope card is on irq 5 with a few other bits and bobs like the network card etc.
Thanks

Not sure if this is it but try disabling your network connection, i used to run with a cheap network card which gave me similar problems, but after buying a managed nic from 3com i have had no problems......
 

andrew

open your mind
Triskele said:
Colin here Rob Triskele's computer... Try lowering the Video Hardware Acceleration slider - it's in the Troubleshooting page of the Advanced section of the Graphics Properties window (right-click on desktop, select Properties, select Settings, click Advanced, select Troubleshooting).

acceleration on zero - no change - also tried it on 2 notches down from full power

nomis said:
Not sure if this is it but try disabling your network connection, i used to run with a cheap network card which gave me similar problems, but after buying a managed nic from 3com i have had no problems......

disabled netwrk connection, unfortunately stilll had the issue...

I've just tried upping my process buffer - Under the ASIO section of the "Audio Driver 2" tab to "jumbo" and increased the latency on the scope card from 3 to 4ms .. the jumbo setting has really helped.

basically when looking at the cpu usage, moving other windows around tends to max that out, which is when logic stops. with these new settings it's taking logic longer to max out. gonne keep experimenting and also try all of the suggestions on http://www.musicxp.net/, which was recommended by the guys on the logic maling list. Wil let yas know how it goes

Cheers Guys

Andrew
 

KungFuHamster

Fabmeister
Hi Andrew,

I still feel that your problem is going to be the number of outputs you have defined. I should think that checking with a smaller number might be productive, as you'll know whether or not it really is the problem. I know you want to mix in the Scope mixer, but if it's not going to be possible to work that way, best to know.

Cheers
 

andrew

open your mind
Hi kung fu -

not sure which parameter you're talking about dude -

do you mean 'maxAudioTracks' in the audio hardware 2 page under the asio section?

you said : I think it's "Options" -> "Audio Configuration" , or possibly "audio routing" or the like. previously but there's no setting in there for physical outputs. I too am at work at the moment, but am interested in trying what you say to see if it helps any more.

Currently, setting the process buffer to jumbo is the only thing that has worked, and it's helped a lot. Instead of just glitching out when another window is moved or twiddled with it will after a while glitch a little, but never actually stop. This is much better. I do really want my 32 stereo outputs from Logic tho so I can mix in Scope.. it's the thing to do according to the Creamware consigenti.

Cheers

Andrew
 

Faction

Proto-col
Maybe ask on Planet Zero how much RAM is recommended for smooth operation with 32 stereo outputs between Logic and the Scope card; it is an awful lot and each output takes up a certain amount of memory.
 

andrew

open your mind
yes, Kungfu mentioned I/O polling and such..but multiple outputs are the way to go according to the Z.

strange, perhaps those guys are all using new sequencers which don't have the same bug set as mine.

i'll ask them. Andrew
 

Leon

Junior Members
Hi,

I use to have exactly the same setup, 3ghz desktop with creamware scope. I know the problem very well, after taking ages to find out what caused it. It's a creamware bug. There is Nothing you can do apart from changing to a different soundcard, which is probably a good idea.
Creamware use to be cutting edge, (though i still love it's routing system) unfortunatly, now it's on it's way out. The company isn't doing so well these days.
Also the quality is no way near as good as the new cards available today. I moved to rme, never had any problems and the quality of my music now sounds 10 times better... really it does (not a sales pitch)

Hope that helps

Leon (wild things, Reality grid)
 
Top